Announcement

Collapse
No announcement yet.

Electrical Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hunter1951
    replied
    Originally posted by Yukoner View Post
    So my BC340 has an electrical issue.
    last time I used I, maybe 1 month ago (which was the first time this winter), it ran fine, but no power, just a very faint glow from the headlight, no hand warmers etc.
    So I figured the voltage regulator was shot. Ordered a new one, and new dimmer switch for the headlight, as it only had high beam, and I had replaced the bulb. Figured the dimmer was broken.
    Replaced the dimmer, new voltage reg. It starts right up, but still no power.
    Pulled the dash cover, quickly checked the wiring harness and connections, all look fine.
    Any ideas?
    Everything was fine last trip out last winter.
    Sure sounds like a ground connection to me.

    Leave a comment:


  • gogglefurnace
    replied
    I'm thinking lighting coil.

    Leave a comment:


  • Yukoner
    started a topic Electrical Issue

    Electrical Issue

    So my BC340 has an electrical issue.
    last time I used I, maybe 1 month ago (which was the first time this winter), it ran fine, but no power, just a very faint glow from the headlight, no hand warmers etc.
    So I figured the voltage regulator was shot. Ordered a new one, and new dimmer switch for the headlight, as it only had high beam, and I had replaced the bulb. Figured the dimmer was broken.
    Replaced the dimmer, new voltage reg. It starts right up, but still no power.
    Pulled the dash cover, quickly checked the wiring harness and connections, all look fine.
    Any ideas?
    Everything was fine last trip out last winter.

Footer Adsense

Collapse
Working...
X