Announcement

Collapse
No announcement yet.

Electricial Problem with 2006 Expedition

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • leo phillips
    replied
    No the headlight bulbs are not burned out ...........going to buy a regulator and try that.thanks for the help and if there is anything else you can let me know I would be thankful..........

    Leave a comment:


  • mod elan
    replied
    Good thing on the rivet in the skid plate. Even some dealers were drilling holes in the regulator not knowing it was there! It could be the regulator just went out. Are the bulbs burnt out in the lights?

    Leave a comment:


  • leo phillips
    replied
    Yes the ski-ddo is totally stock, and it do have a skid plate also it has passenger hand warmers. There are only two fuses both are good. I never installed the rivet in skid plate where the voltage regulator mounts ( the dealer told me not to install it) Any more info you can give me I would appreciate it.

    Leave a comment:


  • mod elan
    replied
    First check the fuses. I can't remember on the fan cooled sleds if there is one or two. It is either by your right foot next to the chaincase or more likely on the frame above the spark plugs and under the dash. Open up the left side panel to access this area and look up above the engine on the aluminum frame.

    Is this machine totally stock or do you have any other electrical accessories or even a skid plate? This will allow me to give you some more things to look for.

    Leave a comment:


  • leo phillips
    replied
    2006 550 Fan Cooled

    Leave a comment:


  • leo phillips
    replied
    The ski-doo is a 550 Fan cooled..

    Leave a comment:


  • mod elan
    replied
    Which Expedition? The 550 has a different system than the 600 and 1000.

    Leave a comment:


  • SusitnaAk
    replied
    Try Here pretty Sharp guys there on that Form.http://www.dootalk.com/forums/index.php

    Leave a comment:


  • leo phillips
    started a topic Electricial Problem with 2006 Expedition

    Electricial Problem with 2006 Expedition

    I have lost all accessories on the ski-doo. I have 12 volts on the headlight plug to body ground, but not the ground on my plug. Can anyone help me with this. Thank-You

Footer Adsense

Collapse
Working...
X