Announcement

Collapse
No announcement yet.

Continental starter adapter/clutch

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Continental starter adapter/clutch

    Getting ready to set up an IO-520 with an adapter/clutch. I would like to hear what some of our members have experienced with this.
    I currently have a new Skytec starter with new style adapter, bad combination here or good?

  • #2
    If you go to the Niagara Air Parts web site they have a read before install page that states the new type adapter is the only one you can use with the light wt. starter., they say it's a 12lb wt. savings. The only thing I've seen is over cranking some starters will twist the housing, the new starters have a label " extended cranking starter" on them because of that. That's about all I know about it, that should be others that have flown them lots.

    Comment


    • #3
      I talked to Skytec today. The new starters will freewheel back to allow the adapter/ clutch spring to disengage and not wear out the shaft and spring.
      I think they said there is actually a clutch on the starter that does that.
      As far as kickbacks....they said no protection. If your getting kickbacks there is something wrong with your mags or engine set up.
      In my research it seems that a lot of the composite propellers are more prone to kickbacks due to the lack of inertia the heavier metal blades provide.
      Food for thought there.

      Comment


      • #4
        I've never had a stock starter or starter clutch give me reason to repair or replace so I've always used what TCM put on.

        Comment


        • #5
          Do the newer lightweight starters draw less current?

          Comment


          • #6
            Originally posted by Mr. Pid View Post
            I've never had a stock starter or starter clutch give me reason to repair or replace so I've always used what TCM put on.
            Departed Black Lake in the Talkeetnas in a new TU206 amphib. Heard a "tsh-tsh" in the David Clarks. Thought it might be the rotating beacon, so turned it off. No deal. Next tried the strobes - - - no deal. Finally turned off the master, then turned it back on. The sound was gone, and I was sure the starter had stuck. It had, and I changed it out, of course. It does happen . . . . .

            Comment


            • #7
              After a little research I think I am going to stick with the set up I have-- new Skytec starter and adapter. Make sure mags and engine are in good shape.
              I am also replacing the old starter solenoid. I don't think I have ever seen one so ancient. Looks like it came off of a model T.
              I don't know about current draw on new Vs. old starters.
              Another bit of info I haven't posted about my aircraft: firewall mounted lightweight battery is my power source.
              This whole setup never seemed to turn the engine over very well. I am hoping after all this it will.

              Comment


              • #8
                I have a PC625 battery on my firewall and it's always worked well. But if the new little starters gave the battery better duration that'd be a consideration for switching. I've only run out of battery one time and that was costly since the engine intake was on fire. Couldn't suck it in with a dead battery. The only guys I know who have new lightweight starters replaced old, sick starters. It's hard to make a decent comparison with that.

                Comment


                • #9
                  I'm with Mr. Pid, my starter drive just started to slip as of late on the cold starts. I'm going to pull it and send it out to rebuild and stay with stock. Waiting too long to overhaul can cost big time if it launches metal goes into the oil system.

                  Comment


                  • #10
                    You aren't using Aeroshell 15-50 are you? That'll make it slip. Changing to Aeroshell straight weight or Phillips multi-vis will usually stop it.

                    Comment


                    • #11
                      Does Camguard affect the clutch, make it slip? Phillips XC20/50 is what I am running

                      Comment


                      • #12
                        Camguard hasn't bothered mine, or anyone else's that I've ever heard about.

                        Comment


                        • #13
                          I've been using shell W 100, it's just starting on cold starts only. I'm just going to overhaul it before the summer. Anybody here done there own overhaul on a drive? I've been thinking it may be all it needs, a new spring and maybe the shaft.

                          Comment

                          Footer Adsense

                          Collapse
                          Working...
                          X