Announcement

Collapse
No announcement yet.

tilt trailer problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • tilt trailer problem

    I have a Floe 8X10 tilt trailer, the aluminum at the pivot point finally gave in and broke. I can fix it, if I get the pivot bolt out, which I have tried a couple times. Does anyone have experience with these things? I dont want to break it more trying to fix it!

  • #2
    Do you have pictures, Iím having a problem understand why you canít remove it?

    Comment


    • #3
      I dont know why I cant remove it either, thats the problem. I plan to flip it over and try again this weekend, I'll get some pics whilst I'm at it.

      Comment


      • #4
        Here is the pivot bolt, it must be welded to the bushing, I gave it a couple wacks with a sledgehammer and it wont budge.

        Comment


        • #5
          From what I can see the top bolt is frozen, thatís what happen when a ss bolt is not used on aluminum. Can you cut it off and drill it out?

          What is the reason for that bolt running horizontal

          Comment


          • #6
            Tenmm, I would try some heat on the bushing but it looks like that wire, (if that is what it is),is pretty close and might be trouble if heat is used. PB Blaster penetrating oil has worked wonders for me a few times. http://www.blastergroup.com.au/PB_Blaster.html. Good luck.

            Comment


            • #7
              It is soaking in PB right now. The other bolt is there to help hold it all together so I can use the trailer, and yes, thats the wiring harness for the lights.

              Comment

              Footer Adsense

              Collapse
              Working...
              X