Announcement

Collapse
No announcement yet.

Propane stove help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Propane stove help

    I bought a cabin a few years ago that has a direct-vent propane stove as an auxillary heat source. It has never operated very reliably so I'm looking for someone to go through it and fix whatever's wrong. It's a Ovre by Heatilator, model DV425L. As close as I can tell by reading the trouble-shooting guide, it needs a new thermocouple, but can't be sure. Can anyone recommend someone in the Willow area to look it over?

  • #2
    Sledneck
    Changing out a thermocouple isn't that difficult.. or expensive..., but getting a Maintenance Tech to go to your cabin will probably be high priced.. My suggestion would be to talk to any of the propane dealers, Anchorage, Palmer, Wasilla and see who sells thermocouples for that make/model...../John

    Comment


    • #3
      Originally posted by Old John View Post
      Sledneck
      Changing out a thermocouple isn't that difficult.. or expensive..., but getting a Maintenance Tech to go to your cabin will probably be high priced.. My suggestion would be to talk to any of the propane dealers, Anchorage, Palmer, Wasilla and see who sells thermocouples for that make/model...../John
      Or just bring the whole thing out of the cabin and bring it to them.
      Tim

      Comment


      • #4
        About a $15 fix just did mine very easy. How far out is the cabin?

        Comment


        • #5
          Thermal couple or thermal pile are both easy to replace and there is really no special one for DV stoves. If you can be a bit more specific on what itís doing then there maybe only an adjustment required. If the stove is several years old then you may still need a small adjustment and to be on the safe side still replace either or both. They are not expensive to replace and not very hard to do. If you have fake logs in the stove be careful and put them back the same way they came or it can soot up the inside of the stove and it just goes downhill from there.

          Hope this helps if you have other questions just hit me up and i will try and answer what i can.
          sigpic
          Sweepint
          Wasilla,
          '' Livn' The Dream ''
          26' Hewescraft Cuddy, twin 115 Yam

          Comment


          • #6
            Thanks for all the help; you've encouraged me to take a stab at fixing it myself. To answer a few of the questions, the cabin is on the road system in Willow. I'm guessing the stove is about 12 years old. The symptoms are: it lights fine and operates for several minutes and then goes out -- when it does, it also extinguishes the pilot. It can relight the pilot and the stove, but the same thing happens after a couple of minutes of operation. I replaced the burner, because it had a large crack in it, but that had no affect. The trouble-shooting guide in the manual I have suggests the problem is the thermo couple, but doesn't list a part #. Although it does list a whole "igniter assembly" -- I think Wholesale Distributors down on Post Road sold it originally, I should probably just go talk to them. Again thanks for your insights, please respond if this gives you any other suggestions

            Comment


            • #7
              That is what mine was doing I went to lowes and got the universial thermocouple and replaced it works like new.

              Comment


              • #8
                Had a similar problem. Almost replaced the thermocupler, but a friend suggested getting an air tanks and blowing out the pilot area. I did and it works fine now.

                Comment


                • #9
                  I had a stove where a flashing by the pilot light was mis adjusted, what would happen is flames from the burner would overheat the thermo-couple and shut the whole thing down. After I fixed the flame diffuser it stayed lit just fine.

                  Comment


                  • #10
                    Thanks everyone. I picked up a thermocouple and will install it in when I get back in a couple of weeks. I'm almost positive that's the problem, but if not it's nice to know I have a few other things to try. I'll definately take a can of air to clean out the area, and I'll definately take a look at adjusting any flashing around the pilot. Lots of good ideas -- thanks!

                    Comment

                    Footer Adsense

                    Collapse
                    Working...
                    X