Announcement

Collapse
No announcement yet.

Scotty line hauler/pot puller displeasure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scotty line hauler/pot puller displeasure

    Wanted to provide some information to those out there that are either owners of or considering the purchase of a Scotty pot puller my recent experience and general displeasure with their product. I purchased their pot puller back in April and used it on 4 or 5 shrimping trips this summer (all prince William sound and within their pot pulling limitations for number of pots). Well back in June it stopped pulling pots pretty much all together and simply comes to a complete stop while under load. The puller worked great the first few times and I though I had an awesome unit in a compact package. Customer service has been friendly although very unhelpful. Tried attempting a repair that they recommend I try with no results. Short of the story is there is no authorized service center here in south central Alaska that works on the pullers and they recommended I ship the product via insured carrier to British Columbia. I informed them that is not a viable and economic solution due to shipping costs from Alaska to technically an international address. So right now I have a 4 month old puller lightly used with essentially no viable warranty.

    For or those wanting an economical and compact puller at this point I would recommend sticking to the ace Brutus and avoid the Scotty puller. If my service status changes on this unit I'll be sure I update this post.

    Anyone else have have any similar experiences?

  • #2
    Does the motor keep running when it stops pulling or does it completely stop ?? maybe its a stripped key way in a shaft somewhere ? I think there is a guy in the valley that works on the ace haulers(sorry don't have his name/number) maybe he could pull it apart and take a look. Really bad that they don't want to at least look at it, but having you send it to BC sure sucks, wonder how they treat folks with downrigger problems. Come and see me if you want bombproof.
    sigpic
    Alaska Shrimp Pots

    Rigid & Folding Shrimp & Crab Pots
    Electra Dyne Pot Haulers
    Ropes, Buoys, Bait
    alaskashrimppots.com
    akshrimppots@mtaonline.net
    907 775 1692

    Comment


    • #3
      It sounds like you have a problem with the boat wiring. I would have someone that know hows to trouble shoot boats electrical systems to look at the insulation.

      Comment


      • #4
        Wiring and related fuse and plug are all brand new pristine and of proper gauge. I used this receptacle for downrigger operation just prior to switching to the puller.

        The capstan simply stops moving under load and continues to move once unloaded. No fuse blowing or over amperage of wire or triggering of the internal overheating protection.

        I did did just receive a voicemail from British Columbia so that was likely Scotty rep returning my call. Will check and post any updates.

        Comment


        • #5
          Originally posted by potbuilder View Post
          Really bad that they don't want to at least look at it...
          How are they supposed to look at it if their service department is in BC? Via text message picture? Maybe fly someone out?

          Comment


          • #6
            Originally posted by Anythingalaska View Post
            How are they supposed to look at it if their service department is in BC? Via text message picture? Maybe fly someone out?

            By taking it to Alaska Performance in anchorage. They are a authorized repaired depots per Scotty web site. If you don't like them there are 22 other repaired depots in the us, 5 in Alaska.

            Comment


            • #7
              Originally posted by MacGyver View Post
              By taking it to Alaska Performance in anchorage. They are a authorized repaired depots per Scotty web site. If you don't like them there are 22 other repaired depots in the us, 5 in Alaska.
              I know about them, but when I looked at their website they say that they service downriggers. They don't say anything about line haulers. I can guarantee the 'repair depo' in my town that is listed wouldn't know what to do with a line hauler; they'd probably just send it out.

              Comment


              • #8
                Thats exactly the case: performance rv and marine here in anchorage does not work on the pot pullers' only the downriggers. Quite the situation. Still have not recieved a return call from scotty.

                Comment


                • #9
                  the problem could be the wireing [ to small ] when under load the pot puller will take a lot of current, an if you have a bad connection , the voltage to the pot puller would go down to a point the puller could stop, take a volt meter [ can be cheep one ] an mesure the voltage at where the power goes into the puller under load , sounds to me you don't have suffent power to the puller under load , every connection, an switch contacts has some resistance. an when you draw lots of current you will have an IR drop across them , it will take voltabe away from the puller , as well it could be in side the puller as well get some one with a little know how with voltage he should be able to fix it , if knot give me a PM an we can get together to fix it [ I HOPE ] SID roud: I work cheep [ coffee ]

                  Comment


                  • #10
                    my scotty works fine, but Im only pulling one of potbuilders pots from 300ft. Downgiggers work great too but when we need fixin they take a while. They call it a lifetime warrente (it takes a lifetime to get it back)
                    Providing trips for multilpe species for over 20 yrs
                    www.kodiakcombos.com

                    Comment


                    • #11
                      sounds like one of the brushes is burnt or sticking. try lightly tapping on brush end of motor and see if it improves. If it does you probably need to get new brushes. Wire size should be no smaller than #6 for the motor..

                      Comment


                      • #12
                        did you check the voltage with a voltmeter under load any thing that could effect the voltage on the brushes ?????? SID roud:

                        Comment


                        • #13
                          Delayed update on the scotty pot puller. Last fall after posting this thread I adjusted the double set nuts within the capstan. This was a recommendation of scotty and thought it was worth a second attempt as I had done it earlier in the season. I backed the nuts all the way out to the end of the threaded rod and walla. The puller has worked flawlessly for two heavy use trips so far this year. It appears that after a break in period the set nut assembly within the capstan torques down to the point of binding the capstan and preventing pulling force.

                          All in all still very happy with the puller working great so far. Hope this may help any others out there having issues. I hope scotty gets warranty service here locally.

                          Comment

                          Footer Adsense

                          Collapse
                          Working...
                          X