Announcement

Collapse
No announcement yet.

Need good Suzuki outboard mechanic.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need good Suzuki outboard mechanic.

    Took the boat out to Finger Lake Thursday to check her out before heading out into the salt this weekend. After a few minutes the engine started to give 2 beeps and the 'chk eng' appeared on the console gauge. It is a 2007 60hp Suzuki. I did not get to use it at all last summer, but she ran perfectly the fall before. I can still get her up to max rpms and actually she sounds really good. Anyways, I would like to get her in somewhere soon to be checked out... who/whom has anyone out there had good luck with? Thanks.

  • #2
    Anchorage Yamaha 3919 Spenard Road sells/services Suzuki. No idea how backed up they may be right now. Will pm you with a couple other possible options.

    Comment


    • #3
      When running were you getting constant water flow out the tattle tail? Is it a direct inject with oil tank?

      Comment


      • #4
        mad...yes constant cool water...is fuel injected, oil is in the engine sump.

        Comment


        • #5
          What gauges do you have hooked to it? Was the check engine light flashing as in making a sequence of numbers, like three flashes a pause and two flashes.

          Comment


          • #6
            Does it have low hours? No idea when suzuki started it but they have a check engine light warning at certain hour intervals for oil change reminder. Something like 20,50,100 hours type deal. Check into that for your year motor. Could be something as simple as resetting the check engine light through the kill switch. It's not the best oil change warning I've seen.

            Comment


            • #7
              I tried the pull out and push in the red kill button within 10 second oil change technique. Same results.

              If you turn the key without starting, 1st position, you get the beeping and indicators as it goes thru it's normal check. then there is 2 beeps. but normal run indicator. Now you can, start the engine (with the water hose attached for cooling) and it starts right up, sounds great, but in about 8 minutes or so the 'chk eng' notation appears and there is 2 beeps every 30 seconds or so.

              Comment


              • #8
                http://www.mdmotors.ru/netcat_files/...is__remont.pdf

                Look at page 14 for error codes. Looks like rectifier and regulator over charging error.
                Those that are successful in Alaska are those who are flexible, and allow the reality of life in Alaska to shape their dreams, vs. trying to force their dreams on the reality of Alaska.

                If you have a tenuous grasp of reality, Alaska is not for you.

                Comment


                • #9
                  Yes, that's what I was thinking based on the codes.

                  Comment


                  • #10
                    Originally posted by mad_yaker View Post
                    When running were you getting constant water flow out the tattle tail? Is it a direct inject with oil tank?
                    My suggestion too,

                    Were you able to see it even under load at full speed? I had a similar issue last year. You could run the throttle all the way up and it would sound great but the impeller stopped pushing water at high rpm under load and would beep on me.
                    Makin fur fins and feathers fly.

                    Comment

                    Footer Adsense

                    Collapse
                    Working...
                    X