Results 1 to 6 of 6

Thread: Artic crap I mean cat

  1. #1
    Member
    Join Date
    Jun 2008
    Location
    Wasilla, Ak
    Posts
    3,904

    Default Artic crap I mean cat

    Well back in August bought a new 2010 650 artic cat. Out here in the valley, even got the winch for free the install was free as well. This thing now has 100 miles on it I think the speedometer doesn't work well it did at the parking lot at tangle lakes parking area. It has been stored in the garage since moose season, I pull it out the other day to move stuff around and the throttle freezes wth so start it up and it stuck wide open . So today pull stuff out of garage now the dang thing won't start battery dead wow. Tomorrow going on trailer to artic cat to get fixed since I'm done goofing off for the year. I have other wheelers that's why I was not in panic mode. Other things it over heated while moose hunting. Our Polaris machines didn't overheat and there radiators were just as muddy as the artic cat. So why post this cause really dissapointed I bought this wheeler cause folks on here had good things to say but man I have 08 700 x2 and that thing has never gave me problems. Maybe I got a lemon who know but I will have it out of my garage next summer!

  2. #2
    Member ret25yo's Avatar
    Join Date
    Sep 2008
    Location
    Unit 13
    Posts
    1,471

    Default

    throttle cable and battery are very common problems.. I just now noticed a rock cut through my (polaris) throttle cable so it has water in it and it froze as well.. I've been through 2 batteries also. never overheated.

    If you cant stand behind the troops in Iraq.. Feel free to stand in front of them.

  3. #3

    Default

    battery issue is known put a tender on them when not using for any length of time and will be fine
    and if your battery was totally dead and frooze if the batteries aren't good the speedo wont work
    of like an 07 650 ( for some reason they do draw battery down i think it is the digital part of the speedo )
    other wise mine have been good

  4. #4
    Moderator AKmud's Avatar
    Join Date
    Oct 2005
    Location
    Wasilla, Alaska, United States
    Posts
    3,185

    Default

    Most of the OEM ATV batterys are worthless. I had to replace the one in my '04 6x6 less than a month after I bought it. Even the dealer (Alaska Power Sports) admitted they were junk and replaced it with an aftermarket brand (Exide) which is still running strong after 6 years.

    As far as your t-cable sticking, check to see if the rubber boots on both ends are seated all the way otherwise water can get in. Also, there is usually an in-line adjuster in the middle of the cable with boots as well you will need to check.
    AKmud
    http://i78.photobucket.com/albums/j96/AKmud/213700RMK1-1.jpg


    The porcupine is a peacful animal yet God still thought it necessary to give him quills....

  5. #5
    Member
    Join Date
    Jun 2008
    Location
    Wasilla, Ak
    Posts
    3,904

    Default

    Thanks guys it still under warranty going take it in tomorrow for speedometer.

  6. #6
    Member greythorn3's Avatar
    Join Date
    Sep 2006
    Location
    Chasin the ladys! away!
    Posts
    2,507

    Default

    all atv's are just pure junk anymore, they dont make them last like the honda 3 wheelers do.
    Semper Fi!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •