Results 1 to 7 of 7

Thread: RMK Clutch?

  1. #1
    New member
    Join Date
    Apr 2008
    Posts
    7

    Default RMK Clutch?

    Im looking for a little information and was hoping that someone could perhaps point me in the right direction. I have an 09 RMK 700, sled runs GREAT although the clutch seems to engage very hard and at high RPM. Not to mention the top speed not as though Im racing it seems to be lacking.
    Was wondering if anyone could point me in the direction of someone in the Anchorage area or in the Valley whod they recommend when it comes to Polaris and Clutches.. Like to get this ironed out before the snow starts and I'm standing in line with the masses waiting on my sled to get worked on....

    Thanks all,

  2. #2
    Member Erik in AK's Avatar
    Join Date
    Jul 2006
    Location
    Anchorage
    Posts
    2,008

    Default

    How many miles on the current belt? As a belt wears, engagement RPM creeps up. Hard riding i.e. hammering on and off the throttle as is typical for mountain sleds, wears a belt out faster.

    Also, your RMK is a purpose-built deep powder sled and it's not clutched or geared for top-end speed. You shouldn't expect much more than 75-80 MPH at 9 grand.

    If you need a professional then see Chad at A2D Sledworks. He's a genuine Poo Guru. They're in a rental garage unit at 501 West Potter between Arctic and C St. 306-3062
    If cave men had been trophy hunters the Wooly Mammoth would be alive today

  3. #3
    Moderator AKmud's Avatar
    Join Date
    Oct 2005
    Location
    Wasilla, Alaska, United States
    Posts
    3,185

    Default

    When was the last time you took the clutch apart and cleaned out the belt dust? It could be just getting sticky and has to make higher RPM to overcome the goo. You can pull the belt off and douse it with brake cleaner but taking it apart obviously does a better job. The secondary clutch needs to be cleaned yearly as well.

    Like Erik said, a worn belt is a likely culprit as well. You can take the belt off and watch the clutch as you come off idle to see how hard it engages. There are specs somewhere that tell what a stock clutch should engage at...

    Also, is the machine stock or did you buy it used? If used, the previous owner may have messed with the fly weights and spring to get higher RPM engagement. There is a number stamped on the side you can check against stock numbers and the color of the spring will tell you which one it is.
    AKmud
    http://i78.photobucket.com/albums/j96/AKmud/213700RMK1-1.jpg


    The porcupine is a peacful animal yet God still thought it necessary to give him quills....

  4. #4
    Member
    Join Date
    Apr 2006
    Location
    Anchorage
    Posts
    3,293

    Default

    ERPAC does some good clutch work. Know what you want and be specific.

  5. #5
    Member Erik in AK's Avatar
    Join Date
    Jul 2006
    Location
    Anchorage
    Posts
    2,008

    Default

    correction to my earlier post: I meant 8 grand not 9, as in RPM. Running perfectly that sled should pull about 8100-8200.
    If cave men had been trophy hunters the Wooly Mammoth would be alive today

  6. #6
    New member
    Join Date
    Apr 2008
    Posts
    7

    Default

    Gents,
    Thanks for the replies on this. Just to answer a few of your questions......
    The sled has about 500mi on it, I purchased it used and it came equipped with a Kevlar belt. As for top speed, I think I seen about 60mph on the last ride. That's about the time my son passed me on his 600RMK! Ouch...
    I'm a bit of a rookie on this clutch stuff. So excuse my ignorance, but I was led to believe that you shouldn't put any chemicals on your clutch?? I was told it would destroy your bushings? All I've been doing to maintain it is to clean it with light soap and some warm water. I'm assuming I'm wrong on that now? Yes/No?... As for if that clutching has been changed from stock, all I can tell you is that it engaged much smoother when I first purchased the sled then now. In addition, the top speed was higher. I do think youre probably right on the possible goo in the clutch though.
    Eric you mentioned Chad at A2D Sledworks, Ill probably see if I cant get together with him in the near future on this.

  7. #7
    New member
    Join Date
    Aug 2009
    Posts
    4

    Default

    As others have said start with the belt when having clutch issues. If you have a glazed or worn belt, it will take more force to engage resulting in a hard takeoff. Inspect it thouroughly and confirm that it is the correct part number for your application.

    Your method for cleaning the sheaves is perfectly acceptable. Just make sure to rinse the soap thoroughly, then when you are done cleaning the sheaves, take a light duty scotch brite pad, and working in a circular, outward motion, scuff the sheaves in a clockwise direction.

    Can you look at the drive spring in the clutch and tell me what color/colors you see? A suspect the black/green should be the stock spring depending on which dealer setup your sled.

    Get the track off the ground, remove the left side panel, and observe the primary clutch while modulating the throttle in and out of engagement. Does it engage smooth and quick or slow, then hard?

    I don't frequent this forum very often, but you can feel free to email me at attention2_detail@hotmail.com or visit our website and contact me with the comment box, those emails go direct to my cellphone, with the answers to these questions maybe we can help determine your problem. We do clutch rebuilds in the instance that you need one, but these sleds are not usually hard on clutches with less than a few thousand miles on them.

    http://www.A2DSledworks.com

    Thanks,
    Chad

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •