Results 1 to 3 of 3

Thread: Need help '93 Polaris 350 4x4

  1. #1
    Member
    Join Date
    Feb 2008
    Location
    Off the road system,AK
    Posts
    372

    Default Need help '93 Polaris 350 4x4

    Hey all,
    I'm trying to find either some help or some manuals/wiring diagrams for my wheeler. She is worn, but was running fine and just up and died one day. I replaced the sparkplug, cleaned the fuel tank and replaced the lines. Then the battery went dead and she doesn't get power even if I use jumper cables on the leads. I'm a little stumped. Is there a repair forum for these things? I've looked around on the web and because of the machines age, it seems like there isn't much out there.
    Any help is greatly appreciated.

    Thanks,

    Mountaintrekker

  2. #2
    New member
    Join Date
    Feb 2010
    Posts
    3

    Default Wiring troubles

    Sounds like old wiring troubles. You need to start off by getting the starter to turn again. then work from there. If you cant get the starter to run even with a jump you must have a loose or corroded battery or starter lead some where. When the jumper cables are hooked up do you get any lights to turn on? Pull off all your plastics and start cleaning and re securing connections.

    Go man go. you are your best mechanic.

  3. #3
    Member
    Join Date
    Feb 2008
    Location
    Off the road system,AK
    Posts
    372

    Default

    Thanks for the encouragement. I'm not getting anything from jumping the leads with a good battery. The battery is toast, that much I know. I'm going to work from the battery terminals on in I guess. Are there fuses on this thing? I haven't seen any yet.


    MOuntaintrekker

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •