Results 1 to 4 of 4

Thread: CED M2 Problems

  1. #1

    Default CED M2 Problems

    The mailman showed up with my CED M2 on Saturday. This morning I took everything out of the packaging and attempted to test it out and the main unit is not working. It will not turn on. I am almost to the point of severly pissed off. I checked the battery, it has plenty of power. Checked to make sure the battery is in right, and checked for good connection. Nothing, still not working. I tried five more 9v's and no luck. The instructions arn't much help either.

    Looks like this main unit is DOA.

    Or am I a moron and missing something here?

  2. #2
    Member
    Join Date
    Feb 2008
    Location
    In an easy chair in Cyberspace
    Posts
    2,316

    Default

    Did you plug the leads in?

    Is the battery in correctly?

    Hold the power button down long enough?

  3. #3

    Default

    Found the problem.

    I pulled the back plate off and found the negative wire is not soldiered to the battery connection posts. Cheap chinese piece of ****

    Time to go pull out the soldiering iron.

  4. #4

    Default

    That got it working.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •