Results 1 to 19 of 19

Thread: Anchor hangs up on trailer when launching...

  1. #1
    Member zigzag's Avatar
    Join Date
    May 2007
    Location
    Kenai
    Posts
    25

    Default Anchor hangs up on trailer when launching...

    I own a weldcraft oceanking and have to remove my anchor from the front everytime I launch or retrieve the boat. If I don't it will catch the front roller. Does anyone else with a hewescraft or weldcraft have this problem? Is there a fix for this?

    Thanks

  2. #2

    Default lots of people have this problem

    I do also............have to take anchor off when launching.......the steeper the ramp and the closer the anchor is to the bow......the worst the hang up. My neighbor with a 27' Trophy has same problem......Not sure there is a solution except for the anchor to be mounted higher (not farther out) so that is above the "drag profile" of the hull as it passes the trailer roller.

  3. #3
    Member
    Join Date
    Apr 2009
    Location
    Anchorage
    Posts
    49

    Default me too

    If I don't take my anchor out of the way it's ugly. Also when trailering my anchor crashes right into the front roller tearing it up more. Did I mention ugly... I think the cure is to lower that roller.

  4. #4
    Member zigzag's Avatar
    Join Date
    May 2007
    Location
    Kenai
    Posts
    25

    Default

    If I lower the roller, the eyelet that I hook the winch cable into will have to be above the roller. Is there any issues with trailering the boat with the roller that low?

  5. #5

    Default

    Are you talking about the anchor hitting anchor roller that's mounted on the bow, or hitting the bow stop on the trailer?

  6. #6
    Member zigzag's Avatar
    Join Date
    May 2007
    Location
    Kenai
    Posts
    25

    Default

    The Bow stop on the trailer.

  7. #7

    Default anchor

    The answer is to lower the bunks on the trailer. This will allow the boat to float sooner and should correct most of the problem.

  8. #8
    Member AkBillyBow's Avatar
    Join Date
    May 2006
    Location
    Palmer, AK
    Posts
    290

    Default

    I have this problem too, but my boat is a catamaran. I am planning on lowering the entire roller and winch set-up. I will use a small steel roller further away from the boat for the winch cable to travel on, to keep the winch pulling the boat forward instead of downwards. I think I have mine all figured out, just need more galvanized steel before I can start.

    Kind of cool, because I thought I was the only guy with this issue!!

    AkBillyBow
    2007 Glacier Bay Cat 2690 Coastal Runner, Twin Honda 150's

  9. #9
    Member GOT TOYS's Avatar
    Join Date
    Apr 2006
    Location
    Kenai
    Posts
    118

    Default crossmember

    I added (all bolt-on) a 2"x2" crossmember across the front 1/3rd part of the trailer. Installed a 12" wide roller in the center of it, and adjusted it to ride just below the keel so it didn't affect normal trailering. When I launch, the roller prevents the bow from dropping, which was the cause for the anchor hang-up. It worked fine without the crossmember when I bought the boat, but I since added a cantilever to my anchor roller so my anchor would deploy without going to the bow to shove it off. The cantilever extended the length enugh to start catching the bow stop roller.
    Kingfisher 2525. 225, 20, and 2hp Hondas.

  10. #10

    Default

    Got Toys: That is exactly what is happening, thanks for pointing that out.

  11. #11

    Default

    Quote Originally Posted by zigzag View Post
    I own a weldcraft oceanking and have to remove my anchor from the front everytime I launch or retrieve the boat. If I don't it will catch the front roller. Does anyone else with a hewescraft or weldcraft have this problem? Is there a fix for this?

    Thanks
    There's too much weight up front in your boat. Get a 225 or put more ballast in the rear. Move your fuel tank back to where your fish hold is. Or, to save you a few bucks do what Got Toys says.

  12. #12
    Member ken210's Avatar
    Join Date
    Jul 2007
    Location
    Somewhere hot and dusty
    Posts
    156

    Default

    This weekend was the 1st time launching my sea runner with my anchor on the boat and it didn't hang up. But I think it's because I have a long pulpit on the front.

  13. #13

    Default

    My Kingfisher does that too. I found if I don't back the trailer in so deep it slides off the trailer flatter and doesn't catch.

  14. #14
    New member
    Join Date
    Sep 2007
    Posts
    11

    Default

    Had same problem with my Kingfisher. Got a new eye welded on apx. 8 inches below the factory eye. The winch then got lowered, end of problem. The new trailers and boats come this way now.

  15. #15
    Member zigzag's Avatar
    Join Date
    May 2007
    Location
    Kenai
    Posts
    25

    Default

    Thanks for the advice. I think I have a few good ideas now and will be able to solve my problem. RMKAK, if you want to buy me a new 225 that would be great!!! Your still a year+ out from getting your GC anyways, so you could use my boat in the meantime when I am work. Sounds like a great deal for both of us.
    Weldcraft Oceanking 220

  16. #16
    Member Sierra Hotel's Avatar
    Join Date
    Feb 2007
    Location
    Chugiak
    Posts
    637

    Default

    I just take the anchor off and stow it . . .

    Lo tech, high speed, and no velcro . . .

  17. #17

    Default

    Quote Originally Posted by ken210 View Post
    This weekend was the 1st time launching my sea runner with my anchor on the boat and it didn't hang up. But I think it's because I have a long pulpit on the front.
    There's no way your pulpit is longer than mine.

  18. #18
    Member GOT TOYS's Avatar
    Join Date
    Apr 2006
    Location
    Kenai
    Posts
    118

    Default Crossmember

    A couple requests for an image of this crossmember. I had some old trailer bunk hardware that I used. Hope this image thing works....
    Attached Images Attached Images
    Kingfisher 2525. 225, 20, and 2hp Hondas.

  19. #19

    Default

    Got Toys - Appreciate the picture - this seems like a quick easy fix. Now I just need time to build.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •