Results 1 to 5 of 5

Thread: Anyone been riding Lost Lake area lately

  1. #1

    Default Anyone been riding Lost Lake area lately

    Has anyone been riding the Lost Lake area resently? If so, what are the conditions like right now? Did you go up from the Primrose Trail side or the other side?

    I'm trying to decide whether to get the sleds ready for summer storage or if there is time for one more weekend ride.

  2. #2


    If you want to get in another ride I recommend you go north up near the Igloo or maybe even Cantwell. I've been wanting to ride Lost Lake all winter but conditions wouldn't allow it and I seriously doubt conditions are any better now. Riding should be good up north for a couple more weeks.

  3. #3


    I have been riding lost lake the last 2 weeks. It has been the best riding I have done all year. Seward just got a foot of snow last week, it was all fluff up there. Nice base with soft snow on top. The trail by fire dept is getting muddy. I dont know how the primrose side is doing. I suggest going and head up the seward side. I had no problems with ice, but the trail is bumpy.

  4. #4
    Member jockomontana's Avatar
    Join Date
    Nov 2007

    Default closed...

    sorry all... Lost lake trail (seward) and Primrose is now closed.
    though I think you can still get in from Snug Harbor rd.

  5. #5


    Yes, access is still available via Snug Harbor road. Anyone rode there in the last few days?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts