Results 1 to 2 of 2

Thread: older polaris battery warning!

  1. #1
    Member akjw7's Avatar
    Join Date
    May 2006

    Default older polaris battery warning!

    Rebuilding a mid 90s sportsman 400 and learned a lesson! If anyone out there is still riding an old wheeler like this maybe I can save you some money...

    Don't run it without the battery!

    Technically I had a battery in mine but it was bad (not just dead it actually tested bad) and since I was still a long ways from putting tires on I was just jumping it with a car battery. With the motor running the jumper cables vibrated thing I know the lights are way way brighter than they should be and then...


    the bulbs started blowing out - no glass explosions but loud pops for sure. By the time my brain processed what was going on and I shut it down all the lights were toast - headlights, speedo, dash, taillight...

    I put a meter on the battery cable with the engine running - over 20 volts! No wonder the lights were uber bright with a tragicly short life span

    So I go scrounging and come across a nice warning in the shop manual that I wish I had read sooner...don't run it without the battery or serious damage to lights can occur! After more research it turns out the voltage regulator cannot handle the stator output without a battery to soak up excess voltage. Hopefully a simple dead battery doesn't cause this, but a bad battery certainly does (mine was hooked up).

    Not sure what happens if you're out in the sticks and have a rollover or something damage a battery, but it wouldn't be pretty.

  2. #2


    I had a similar experience with my '97 425 Magnum. Blew out all the lights and I had to replace every single bulb.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts