Results 1 to 6 of 6

Thread: mercery RPM's

  1. #1
    Member
    Join Date
    Oct 2007
    Location
    Wasilla, Alaska, United States
    Posts
    106

    Default mercery RPM's

    I have a 2004 mercery 2 stroke 90/65 jet I was wondering what I should be getting for RPM's at top end? If any one has an idea I would like to find out. Right now top end is about 4800-4900 rpm. Just wondering if I should be getting more out of it?

    Thank you for your time and knowledge.

  2. #2

    Default Mercury outboard.

    I believe that motor should be getting around 5200 rpm's but that probably without propulsion. I have a 150hp before jet and have'nt seen 5200 while in the water yet.

  3. #3
    Member
    Join Date
    Apr 2008
    Location
    galena
    Posts
    139

    Default 65jet rpm

    hi,,ive got the same motor on an 18ft alumacraft im getting 5400rpms out of it,,hopes this helps

  4. #4
    Member
    Join Date
    Sep 2007
    Location
    Fairbanks
    Posts
    65

    Default

    Do you have the correct impeller in the motor? How much clearance between the impeller and the liner? There should be about .030" clearance.
    With this clrarance and a good impeller, you should run between 5,000 and 5200 rpm.
    When you reach 5,600 rpm(approx), you need to move a shim from the bottom of the impeller to the top.
    If you can't get that rpm range, look for an obstruction in the discharge area of the jet. Look deep, that is where I found the rocks that were keeping my RPM down.The impeller acts like a dyno, too much pressure, and it "stalls" the engine, too little pressure, it overrevs.
    You are looking for the maximum efficiency from the impeller. It comes between the aforementioned RPM's.

  5. #5

    Default

    Quote Originally Posted by 21'-Grayling View Post
    I believe that motor should be getting around 5200 rpm's but that probably without propulsion. I have a 150hp before jet and have'nt seen 5200 while in the water yet.
    I was out on the Sue and checked max rpm's while in motion since last response and i hit 5200 while being loaded with 3 people and fishing gear.

  6. #6
    Member
    Join Date
    Oct 2007
    Location
    Wasilla, Alaska, United States
    Posts
    106

    Default Thanks

    Thanks for the info guys. I changed out my liner and impellar with no change. Since then I found out that my tach was messed up.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •