Results 1 to 3 of 3

Thread: mechanical trouble - outboard ?

  1. #1
    Join Date
    Dec 2007

    Default mechanical trouble - outboard ?

    I has some mechanical issues this weekend and am wondering if anyone else has run into it..
    johnson 2000 with a jet 115,
    Was returning home from the cabin and motor started just fine let it warm up and everyone jumped in.
    Ran for 15-20 minutes and I lost all rpms and the motor completely quit without me touching the throttle.
    No alarms, no horn.
    popped the cowl and had fuel to the carbs, no water in the racor.
    cranked and cranked but would not restart.
    got ready to tow and on a last ditch effort cleaned the plugs and got the motor running by holding the throttle lever on the powerhead open, but ran rough.
    finally finessed it from the console and was able to drive home as 5k rmps motor sounded fine...

    while we were troubleshooting it, noticed that the spark in #4 was weak and it appeared that the compression was low (thumb test) in 3 and 4.

    But after getting it started everything ran fine didnt miss and was running normal rmps?
    Anyone have the "pleasure" of this scenario in the past and how did you fix it?

  2. #2


    Sounded like what happened to me a few years ago and wound up being a crimped fuel line. Ran fine for a short while then started chugging until it just stopped. Tried and tried to get it started again but no good. After 30 minutes of so it started back up and acted like it was flooded, ran rough, then smoothed out again for a short time and the same thing happened again. This happened a few times before I found out the line was crimped and was "starving" the motor. After a few minutes, enough fuel "leaked through the crimped line and it would run fine again until that fuel (in the line) was used up. Found the crimp later at home, rerouted so it wouldn't crimp back up, and the motor has run fine ever since. It might be worth a look...

  3. #3
    Join Date
    Mar 2008

    Default kill switch problem?

    My Evinrude has been giving me trouble. Dying when I least need it, then running fine later. The little rubber button that snaps on my kill switch had dry rotted and was not holding on the kill switch tightly. The action of moving the throttle or key would jiggle the lanyard and kill switch into life. A subtle problem that will drive you crazy finding it. Might be worth a look.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts