Results 1 to 4 of 4

Thread: 2004 polaris 330 magnum

  1. #1
    Member
    Join Date
    Oct 2006
    Location
    Anchorage
    Posts
    516

    Default 2004 polaris 330 magnum

    I bought my wife this atv 4x4 and it leaks oil. Also when I opened the oil fill cap it was under pressure. Is this normal for this machine??? It seems to me that exuast in the oil line would be bad. Does anyone recomend a mechanic in town!!! I need to get this thing running before summer is here!!

    Thanks for any help!
    Good judgment comes from experience, and a lot of that comes from bad judgment.

  2. #2
    Member AKMuddy's Avatar
    Join Date
    Aug 2007
    Location
    Palmer, AK
    Posts
    458

    Default

    Welcome to the "Popo" world...I know, I own one! Will never do it again.
    2007 Yamaha Rhino 660
    2007 Yamaha Grizzly 700 SE w/EPS
    http://www.grizzlycentral.com/

  3. #3

    Default Check your

    crankcase breather into the airbox. Pressure without the motor running is bad juju.
    Mike
    Mike
    www.alaskaatvclub.org
    There is a faster way off the mountain, might hurt a little though.

  4. #4
    Member
    Join Date
    Oct 2006
    Location
    Anchorage
    Posts
    516

    Default my fault

    I opened the oil fill while running!!! Also what do you mean about PoPo??

    Thanks for the answers so far!!!!!!
    Good judgment comes from experience, and a lot of that comes from bad judgment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •