Results 1 to 4 of 4

Thread: Yamaha 115/80 Jet Impeller issue

  1. #1
    Member
    Join Date
    Apr 2012
    Location
    Tightwaad Airranch
    Posts
    234

    Default Yamaha 115/80 Jet Impeller issue

    Bear with me I am a novice in the group. I just replaced the foot on my 115/80 and find the impeller rubbing on the liner. I was told that I need to shim the foot in order to stop the rubbing. Does he mean that I have to remove the impeller and add washers to move the impeller up as the liner is conical? I hate to dissemble something when it's not necessary. All the input I can get will be most appreciated.



    Sent from my iPad using Tapatalk

  2. #2
    Member
    Join Date
    Apr 2006
    Location
    Chugiak
    Posts
    211

    Default

    Take a washer from the top and put it on the bottom then test it for clearance, I'd it still rubs move another from top to bottom. You want about a match book (1/32) width between the impeller and foot. As it wears you'll want to move shims from the bottom to the top to keep the clearance tight.

  3. #3
    Member
    Join Date
    Apr 2012
    Location
    Tightwaad Airranch
    Posts
    234

    Default

    Thanks, let's hope the impeller will come off


    Sent from my iPad using Tapatalk

  4. #4
    Member
    Join Date
    Apr 2012
    Location
    Tightwaad Airranch
    Posts
    234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •