Results 1 to 4 of 4

Thread: Help with blown fuse? on Merc Sportjet

  1. #1
    Member
    Join Date
    Jun 2010
    Location
    Pennsylvania
    Posts
    100

    Default Help with blown fuse? on Merc Sportjet

    Hi Everyone-

    Started the boat up to go home and was cruising along and noticed no Gauges were operating. Mercury Smartcraft gauge had no power, the Gas and Volt meters no power.

    Is this a blown fuse and if so is it located on the motor somewhere or under the steering wheel up under the console somewhere? Im not sure where to begin searching.

    Thanks,

    Mike

  2. #2
    Member
    Join Date
    Apr 2006
    Location
    Anchorage
    Posts
    3,246

    Default

    There could be fuses in both location that power the gauges. Sound like it's a good time to check all the fuses.

  3. #3
    Member DRIFTER_016's Avatar
    Join Date
    Oct 2007
    Location
    Yellowknife, NWT
    Posts
    3,318

    Default

    Check the fuse boxes on the motor.
    The Smart craft guages are fed power through the harness that connects to the engine not @ the guage end.
    Also check your fuses @ the battery as there could possibly be one there as well.
    And finally you can check the under dash fuses if the other locations are good.

  4. #4
    Member
    Join Date
    Jun 2010
    Location
    Pennsylvania
    Posts
    100

    Default

    Thanks MacGyver and Drifter. There was a junction box under the dash with 3 large connectors that go to the smart craft gauge and the gas and voltage.....and one was loose...easy fix for the day.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •