Results 1 to 4 of 4

Thread: 1999 arctic cat 4x4 300

  1. #1
    Member
    Join Date
    Jul 2012
    Location
    Wasilla
    Posts
    110

    Default 1999 arctic cat 4x4 300

    Hello,

    I'm ready to burn it...

    it's hard or impossible to start... Tries to start sometimes... Smells like it's flooded ... With or without choke...

    Drained, removed and cleaned tank and pep cock/screen... New high octane gas...

    cleaned carb twice... Soaked overnight in carb acid "third cleaning"....

    cold compression check of 120-125 psi

    adjusted valve lash...

    replaced plug twice...

    replaced coil...

    next is mag... I have not tested it yet due to buying house and moving...

    any first hand experience on these machines...

    i read about fly wheels coming apart...

    It won't even start with either now...

    gary

  2. #2

    Default

    I assume there is spark?


    Sent from my iPhone using Tapatalk

  3. #3

    Default

    Kill switch??


    Sent from my iPhone using Tapatalk

  4. #4
    Member
    Join Date
    Jul 2012
    Location
    Wasilla
    Posts
    110

    Default

    Oh of course there is spark... Don't seem real strong/hot... That's why I replaced the coil... It won't jump from lead to ground but will fire if you put the plug in then to ground ...

    put another new plug in yesterday and fired right up... No choke... No either... Nothing...

    took it down the rode and all good till I get to wide open throttle then it starts popping.. Not really backfiring .... Almost like a governor kicking in....

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •