Results 1 to 5 of 5

Thread: check engine light

  1. #1

    Default check engine light

    The check engine light on my 2011 Big Boss 6x6 came on a few times on a ride last week end and a few times I was getting poor throttle response and low rpms. Oil clean and full, air filter clean and dry and radiator fluid ok. We did hit some mud holes. Any ideas as to what caused this? Water in fuel?

  2. #2

    Default

    Sure you did this but check the front of the radiator and see if it is covered in muck, etc. My 500 will block up and will do the same.

  3. #3
    New member
    Join Date
    Jan 2010
    Location
    Eagle River
    Posts
    2,022

    Default

    Quote Originally Posted by northway View Post
    Sure you did this but check the front of the radiator and see if it is covered in muck, etc. My 500 will block up and will do the same.
    That is a BIG issue with the water cooled machines, the radiator gets overlooked when time comes to clean the machines. Like everything else that needs a wash after an outing the radiator needs it twice as much. If at all possible clean it from the back side as well as possible then from the front, finish from the back.

  4. #4
    Member Roger's Avatar
    Join Date
    Apr 2006
    Location
    Sunshine Alaska
    Posts
    2,050

    Default

    Also check your plug before I shunned Polaris 13 years ago the plug fouled all the time and would cause the same thing.
    PEOPLE SAY I HAVE A.D.D I DON'T UNDERSTA.....OH LOOK A MOOSE !!!

  5. #5
    Member LIVIN907's Avatar
    Join Date
    Jan 2013
    Location
    Palmer, AK MERICA
    Posts
    199

    Default

    Mud blocked up the radiator my old kodiak I had while out at King river used my sons super soaker to blast the mud off. Caused a coolant light to come on at the time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •