Results 1 to 4 of 4

Thread: Help with my arctic cat 500 atv

  1. #1
    Member akblackdawg's Avatar
    Join Date
    Aug 2009
    Location
    Wasilla
    Posts
    1,456

    Default Help with my arctic cat 500 atv

    I have a older 2000 ac500 liquid cool that I am trying to figure out. It quit running just before the last good snow and has been sitting since then. Worked on it today since it was nice out, I don't have a heated garage or anything like that. with the air cleaner and the box off, there is a tube coming from the back of the engine into the front of the air cleaner, it empties into a compartment on the front of the air cleaner and there is a drain at the bottom which at one time had a hose connected to it, only about a inch with the clamp is there now. Now I can start the motor, but the tube, about 1/2 inch rubber, on the top of the rear part of the motor, spits and flows water out of it and of course when I connected it to the air cleaner box, that water drains though and out the bottom. it appears to be dirty water from the coolong system. upon looking around the bottom of the engine, I do not find a disconnected hose or anything that should connect to it, does anybody have any knowledge of where this bottom connection on the air cleaner connects too. The machine did get hot a couple times this winter when I left it ideling too long while plowing snow, but other then that, it had run fine until I got into it today, i fixed the starting problem but now have the problem with the coolant. Any advice appreciated. Bud
    Wasilla

  2. #2

    Default

    So it's been a whiel since i've been under the hood of one of these but. you should have no coolant lines vent or other running to the air cleaner. there should however should be a vent coming from the gas tank running into the air box. If you can email me a pic I can be a lot more help.

  3. #3
    Member akblackdawg's Avatar
    Join Date
    Aug 2009
    Location
    Wasilla
    Posts
    1,456

    Default

    ac 500.jpgThis is pretty blurry, I guess the auto focus isn't up to par on my camera. I stuck a ball point pin in the outlet of the hose, if you look to the right you will see where the hose comes out of the top of the motor or trani, i think trani, the hose routes back and around and then where the ball point pin is, it goes into the air cleaner compartment.
    Wasilla

  4. #4
    Member
    Join Date
    Apr 2006
    Posts
    2,925

    Default

    Quote Originally Posted by akblackdawg View Post
    ac 500.jpgThis is pretty blurry, I guess the auto focus isn't up to par on my camera. I stuck a ball point pin in the outlet of the hose, if you look to the right you will see where the hose comes out of the top of the motor or trani, i think trani, the hose routes back and around and then where the ball point pin is, it goes into the air cleaner compartment.
    blackdawg I would suggest you put a post over on arcticchat..some good helpful folks that could probably help you out in a hurry. Also there are some links over there for free downloads for parts and service manuels...
    here is a link to the parts diagrams just follow links to your model...hope this helps you out a little
    dave

    http://store.arcticcat.com/Parts

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •