Results 1 to 4 of 4

Thread: 04 Skandic Sport 550F random alarm lights and bulbs blown

  1. #1
    Member
    Join Date
    Jan 2009
    Location
    Fairbanks
    Posts
    201

    Default 04 Skandic Sport 550F random alarm lights and bulbs blown

    OK sledheads - need some help here.

    Blown bulbs, all the alarm lights on, LCD speedometer blank, hotgrips HOT! Suspect bad voltage regulator - yep it's cracked in half, scorched on the inside when I pry it apart. Replace it. Test drive down road - all is fine for 1 mile them BOOM same problems all crop up again. Turn machine off/on, problem clears up, drive another mile, but them BOOM it repeats. New VR looks intact.

    Ideas on where to look next to resolve?

    XL

  2. #2
    New member
    Join Date
    Jan 2010
    Location
    Eagle River
    Posts
    2,022

    Default

    I would be suspect of the instrument cluster having a short or the like.

  3. #3
    Member Bsj425's Avatar
    Join Date
    Oct 2009
    Location
    North Pole, Alaska
    Posts
    1,060

    Default

    Bad stator. That's where the VR gets its power jack up your track pull headlight and check the power with a multi meter should be at steady 12 v and should go no higher than 15 @ full rev. If it is going above that you need to replace stator and sadly probably a new VR as it probably tried the new one too.

  4. #4
    Member
    Join Date
    Jan 2009
    Location
    Fairbanks
    Posts
    201

    Default

    Sorted it out - removed VR, cleaned it plus chassis mount point well with steel wool, reattached tightly. 3 mile, 60 mph test = no alarms and headlight bulb stayed intact. I think that did the trick!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •