Results 1 to 4 of 4

Thread: Honda Outboard Help

  1. #1
    Member JR2's Avatar
    Join Date
    May 2009
    Location
    Eagle River
    Posts
    2,129

    Default Honda Outboard Help

    Out running around Whittier this past weened and after sitting for a couple hours in a cove when I restarted my engines one of them threw a check engine light on on the key panel. The error on my tach for that motor says its a PGM-FI error. I went ahead and ran the motor to get back to port (from South Culross) and the motor ran fine and had lots of power. Today I had to go grab my shrimp pots out of black stone and the motor ran fine but would not run past about 5500 rpm when normally I can redline it at 6K. Did some reading on my cell phone last night in the harbor and everything points to a fuel filter/water separator problem, but I am not getting the water in fuel error on the tach so I am leaning toward the fuel filter. Would a plugged up fuel filter throw a code and make the motor not run at 100%? and if that is the problem how did it plug up with a racor in front of it?

    My problem is that I had to leave the boat in Whittier as its oversize and I have to go back to the slope for two weeks on the 5th. I have people coming from out of town when I get back to town so I need to figure this out and take the parts I need to fix it. I have spoken to a couple charter guys who use Honda outboards that said as long as the motor runs its fine, but it bothers me.

    Any ideas?
    2007 Kingfisher 2825 - Stor Fisk

    Civilization ends at the waterline. Beyond that, we all enter the food chain, and not always right at the top. -- Hunter S. Thompson

  2. #2
    Member JR2's Avatar
    Join Date
    May 2009
    Location
    Eagle River
    Posts
    2,129

    Default

    Put this in the wrong Forum.... can a mod please delete it. I will repost it in Power Boating.
    2007 Kingfisher 2825 - Stor Fisk

    Civilization ends at the waterline. Beyond that, we all enter the food chain, and not always right at the top. -- Hunter S. Thompson

  3. #3
    Member Cliffhanger's Avatar
    Join Date
    Apr 2006
    Location
    Homer, Alaska, USA
    Posts
    732

    Default

    How new is your engine? I had a oxygen sensor go out on my brand new Honda 225 and found out that the 2009 models had this problem. Honda had a recall notice on it and paid for the replacement. Call your local dealer.

  4. #4
    Member Jack in Alaska's Avatar
    Join Date
    May 2010
    Location
    Ninilchik/Anchorage/Arizona
    Posts
    91

    Default

    JR2........

    your boat is gone from Whittier and at the Honda Doctor in Anchorage. Hang onto your wallet.

    Dad

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •